View Issue Details

IDProjectCategoryView StatusLast Update
0003660Ham Radio DeluxeBugpublic2020-04-08 01:41
ReporterWA9PIEAssigned ToDOUG 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.275 
Summary0003660: Add submode to ADIF file that goes to eQSL.cc, HRDLog.net, ClubLog, and QRZ
DescriptionWith the correct changes that were made in the 6.7.0.269 release regarding getting QSOs into Logbook correctly, with confirmation matches in the LOTW download, we missed adding submode to eQSL.cc, HRDLog.net, ClubLog, and QRZ.

As a result, FT4 QSOs are only uploading as MFSK (as it's the Mode).

This request is being made to add submode to the file that gets sent to these sites when Logbook uploads them.

The attached image shows the tear-offs where these uploads are executed (though most folks select the automatic upload).
Steps To Reproduce- Create an FT4 QSO
- Begin the upload to eQSL.cc (Logbook > File > eQSL.cc > Upload)
- After the upload completes, you will be able to see the content of the file that was sent to eQSL.cc; it's missing submode
- Login to your eQSL.cc account and find the QSO. It will be incorrectly shown with the Mode of MFSK. It should show "MFSK (FT4)"
TagsNo tags attached.
ModuleLogbook
Sub-ModuleData
Testing Beta Successful

Activities

WA9PIE

2020-04-03 04:54

administrator  

AddSubmodeToADIF.png (122,301 bytes)
AddSubmodeToADIF.png (122,301 bytes)

DOUG

2020-04-04 17:51

developer   ~0009645

Added the submode to the above "uploads". Just kicked off a beta build with these change in it.

WA9PIE

2020-04-04 20:19

administrator   ~0009646

Doug,

I just tested this (270) and there's still no Submode in the uploaded files for these.

Mike

WA9PIE

2020-04-05 00:25

administrator   ~0009647

Doug,

I've just tested the 271 release build. I confirm that there's a difference here that involves a use case I didn't account for (and you'll see why in a moment).

WORKS: The use case where the user uploads the QSO manually using the menus in the original description works.

NO WORKING: The more common use case where the QSOs are automatically uploaded. In this case, the data that gets sent must be different than when it's sent automatically. (I have NO idea what developer thought that would be a good idea. But it's likely been like this since 2014.)

I'm attaching an image that shows where these automatic settings are.

AutomaticUpload.png (116,013 bytes)
AutomaticUpload.png (116,013 bytes)

WA9PIE

2020-04-05 07:27

administrator   ~0009649

Regarding HRDLog.net, the following is a response from the developer for that website:

====================

HRDLOG.net supports SUBMODE field.

I have done a test using HRD Logbook version 6.7.0.269, added a new QSO, Mode=MFSK, Submode=FT4.
As you can see in the Logfile (HRD Logbook -> View -> Logfile), SUBMODE field isn't sent to HRDLOG.net

11:20:30 ALE Adding Entry "I2TEST" to Logbook.
11:20:30 Add Opening database IY1OD - 2019 - Access
11:20:30 Add Open status 1
11:20:30 Add Opening table TABLE_HRD_CONTACTS_V01
11:20:30 WebLog Upload Submitted OK
11:20:30 WebLog Upload Upload data .: Callsign=TEST&Code=0000000000&ADIFData=<QSO_DATE:8>20200405+<TIME_ON:6>091440+<CALL:6>I2TEST+<BAND:3>40m+<FREQ:8>7.100000+<MODE:4>MFSK+<RST_SENT:3>599+<RST_RCVD:3>599+<STATION_CALLSIGN:6>IW1QLH+<DXCC:3>248+<DISTANCE:8>0.000000+<QSL_SENT:1>N+<QSL_RCVD:1>N+<QSL_SENT_VIA:1>D+<EOR> -
11:20:30 WebLog Upload Status ......: 1

DOUG

2020-04-07 22:32

developer   ~0009659

Yes you are correct, there was some different logic for the automatic background upload. Sub mode has been added for these now.

DOUG

2020-04-07 22:33

developer   ~0009660

272 beta build has been kicked off.

WA9PIE

2020-04-08 01:41

administrator   ~0009661

I tested this personally and it now works as required.

Issue History

Date Modified Username Field Change
2020-04-03 04:54 WA9PIE New Issue
2020-04-03 04:54 WA9PIE Status new => assigned
2020-04-03 04:54 WA9PIE Assigned To => DOUG
2020-04-03 04:54 WA9PIE File Added: AddSubmodeToADIF.png
2020-04-04 17:51 DOUG Note Added: 0009645
2020-04-04 20:19 WA9PIE Description Updated View Revisions
2020-04-04 20:19 WA9PIE Steps to Reproduce Updated View Revisions
2020-04-04 20:19 WA9PIE Testing Not Started => Alpha Failed
2020-04-04 20:19 WA9PIE Note Added: 0009646
2020-04-05 00:25 WA9PIE File Added: AutomaticUpload.png
2020-04-05 00:25 WA9PIE Note Added: 0009647
2020-04-05 07:27 WA9PIE Note Added: 0009649
2020-04-07 22:32 DOUG Note Added: 0009659
2020-04-07 22:33 DOUG Note Added: 0009660
2020-04-08 01:40 WA9PIE Project 4 - Business Priorities => Ham Radio Deluxe
2020-04-08 01:41 WA9PIE Status assigned => closed
2020-04-08 01:41 WA9PIE Resolution open => fixed
2020-04-08 01:41 WA9PIE Fixed in Version => 6.7.0.275
2020-04-08 01:41 WA9PIE Testing Alpha Failed => Beta Successful
2020-04-08 01:41 WA9PIE Note Added: 0009661