View Issue Details

IDProjectCategoryView StatusLast Update
0003663Ham Radio DeluxeBugpublic2020-08-03 03:14
ReporterWA9PIEAssigned ToWA9PIE 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version6.7.0.287 
Target VersionFixed in Version6.7.0.301 
Summary0003663: ALE "Start" time is not being properly reset when the user has set it to "Set by User"
DescriptionIf the Start Time is "Set by the User", and if the user keeps the ALE open to continue adding QSOs, then the Start Time isn't being reset after saving a QSO. This causes a problem where the QSO record has the wrong time in it and that can prevent the QSO from matching on LOTW download.
Steps To Reproduce- open Logbook
- open an ALE
- in the ALE menu, go to Options > Date/Times > Start > Set by User
- for good measure, close the ALE and open it again; note the Start time is the value of the machine time when the ALE was opened
- enter a callsign and hit the TAB key or click the "Lookup" button; note that the Start time has not changed (nor has Stop time)
Additional InformationCHANGE: Here's the change that needs to be made.

When Start Time option is set to "Set by User" (within the ALE, Options > Date/Times > Start > Set by User), then...

Reset the Start Time to the PC clock when the user performs a callsign lookup (this happens when the user either tabs out of the callsign field or clicks on the "Lookup" button). Do the same for the Stop Time.

(This is the same function that occurs when the Start Time option is set to "Set by User" and the user presses the F2 key, or F3 for Stop Time. Just run these same functions (run for F2 or F3) when Start Time option is "Set by User" (F2) and Stop Time is "Set by User" (F3) and the user performs a callsign lookup.)
TagsNo tags attached.
ModuleLogbook
Sub-ModuleData
Testing Beta Successful

Relationships

duplicate of 0003661 new 1 - Backlog ALE Start Time not functioning as it should 
related to 0003701 closedWA9PIE Ham Radio Deluxe Lookup while in update mode overwrites QSO date/time 

Activities

DOUG

2020-05-24 15:10

developer   ~0009683

just kicked off a build with this change in it.

WA9PIE

2020-06-12 21:14

administrator   ~0009688

I tested this in the 6.7.0.280 build. It's "half done." It does work when the "Lookup" button is selected in the ALE. But it's not working when the user tabs out of the "Call" field.

IMPORTANT: Reference
- this topic is only in the ALE
- it's only used in these two cases
>> when the Start time is set to "Set by User" (Options > Date/Times > Start > Current Time); this causes the Start time to fill with Date & Time of the PC at that moment
>> when the Stop time is set to "Set by User" (Options > Date/Times > Stop > Current Time); this causes the Stop time to fill with Date & Time of the PC at that moment
- it happens when these settings exist and the user does one of the following two things:
>> enters data into the Call field and clicks the "Lookup" button in the ALE
>> enters data into the Call field and TAB key to exit the Call field in the ALE (this is the part that's not happening in the 6.7.0.280 build)

WA9PIE

2020-06-17 21:55

administrator   ~0009690

I tested this in 6.7.0.282 and I find it to be working as designed.

g3ucq

2020-07-02 04:37

viewer   ~0009706

Fixed.

k2ie

2020-07-02 09:21

viewer   ~0009717

Fixed.

WA9PIE

2020-07-06 23:10

administrator   ~0009730

Validated by beta testers; marking as Closed

WA9PIE

2020-07-09 20:25

administrator   ~0009740

We need to have another look at this.

This feature works correctly when creating a new record in the database.

However... it's also modifying the time when someone updates an existing record. (It may even attempt to change the time when the user tries to view an existing record.) When an existing record is opened, none of the fields should change unless the user manually changes them.

DOUG

2020-07-11 22:08

developer   ~0009744

I reproduced this one by hitting the lookup button again, changed it so that if you are modifying an existing record this will not happen.

g3ucq

2020-07-13 04:01

viewer   ~0009768

Fixed

vk2byi

2020-07-13 04:41

viewer   ~0009775

Fixed

WA9PIE

2020-07-13 04:54

administrator   ~0009778

The famous "Start time problem" is solved.

Issue History

Date Modified Username Field Change
2020-04-09 23:13 WA9PIE New Issue
2020-04-09 23:13 WA9PIE Status new => assigned
2020-04-09 23:13 WA9PIE Assigned To => DOUG
2020-05-04 22:00 DOUG Assigned To DOUG => WILL
2020-05-24 15:10 DOUG Assigned To WILL => WA9PIE
2020-05-24 15:10 DOUG Status assigned => resolved
2020-05-24 15:10 DOUG Resolution open => fixed
2020-05-24 15:10 DOUG Note Added: 0009683
2020-06-12 21:14 WA9PIE Status resolved => feedback
2020-06-12 21:14 WA9PIE Resolution fixed => reopened
2020-06-12 21:14 WA9PIE Product Version => 67.0.280
2020-06-12 21:14 WA9PIE Testing Not Started => Alpha Failed
2020-06-12 21:14 WA9PIE Note Added: 0009688
2020-06-17 21:55 WA9PIE Status feedback => resolved
2020-06-17 21:55 WA9PIE Resolution reopened => fixed
2020-06-17 21:55 WA9PIE Product Version 67.0.280 =>
2020-06-17 21:55 WA9PIE Fixed in Version => 6.7.0.282
2020-06-17 21:55 WA9PIE Testing Alpha Failed => Alpha Successful
2020-06-17 21:55 WA9PIE Note Added: 0009690
2020-06-27 20:18 WA9PIE Relationship added duplicate of 0003661
2020-07-02 01:11 WA9PIE Fixed in Version 6.7.0.282 => 6.7.0.285
2020-07-02 04:37 g3ucq Note Added: 0009706
2020-07-02 09:21 k2ie Note Added: 0009717
2020-07-06 23:10 WA9PIE Status resolved => closed
2020-07-06 23:10 WA9PIE Testing Alpha Successful => Beta Successful
2020-07-06 23:10 WA9PIE Note Added: 0009730
2020-07-09 20:25 WA9PIE Assigned To WA9PIE => WILL
2020-07-09 20:25 WA9PIE Status closed => assigned
2020-07-09 20:25 WA9PIE Resolution fixed => reopened
2020-07-09 20:25 WA9PIE Product Version => 6.7.0.287
2020-07-09 20:25 WA9PIE Fixed in Version 6.7.0.285 =>
2020-07-09 20:25 WA9PIE Testing Beta Successful => Beta Failed
2020-07-09 20:25 WA9PIE Note Added: 0009740
2020-07-11 19:56 DOUG Assigned To WILL => DOUG
2020-07-11 22:08 DOUG Status assigned => resolved
2020-07-11 22:08 DOUG Resolution reopened => fixed
2020-07-11 22:08 DOUG Note Added: 0009744
2020-07-12 02:16 WA9PIE Relationship added related to 0003701
2020-07-12 20:25 WA9PIE Fixed in Version => 6.7.0.290
2020-07-13 04:01 g3ucq Note Added: 0009768
2020-07-13 04:41 vk2byi Note Added: 0009775
2020-07-13 04:54 WA9PIE Status resolved => closed
2020-07-13 04:54 WA9PIE Testing Beta Failed => Beta Successful
2020-07-13 04:54 WA9PIE Note Added: 0009778
2020-07-21 05:12 WA9PIE Assigned To DOUG => WA9PIE
2020-08-03 03:12 WA9PIE Fixed in Version 6.7.0.290 => 6.7.0.301
2020-08-03 03:14 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe