View Issue Details

IDProjectCategoryView StatusLast Update
0003665Ham Radio DeluxeEnhancementpublic2020-08-03 03:14
ReporterWA9PIEAssigned ToWA9PIE 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version6.7.0.290 
Target VersionFixed in Version6.7.0.301 
Summary0003665: Add option to include Comment field from prior QSO to be included in callsign lookup
DescriptionAdd option to that allows the contents from the most recent QSO's Comment field to be pulled in during the callsign lookup process when Logbook is an enabled method.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleData
Testing Beta Successful

Activities

WA9PIE

2020-06-12 21:17

administrator   ~0009689

It looks like the option for this showed up in the 6.7.0.280 build. It's not working.

What should happen is...

When this option is enabled, and the user invokes the callsign lookup within the ALE, the contents of the last QSO with that callsign is brought into the ALE so that the user can see it... then they can leave it, delete it, or modify the contents of the Comment field prior to saving the new QSO.

WA9PIE

2020-06-18 01:24

administrator   ~0009692

No change in 6.7.0.282

WILL

2020-06-18 14:43

developer   ~0009696

I think there's something I'm not understanding with this issue. When I lookup in the ALE it adds the last comment to the comment field. I attached a snip of what my screen looks like. Is there somewhere else the comment needs to show up?

3665_282.PNG (58,666 bytes)
3665_282.PNG (58,666 bytes)

WA9PIE

2020-07-02 07:16

administrator   ~0009713

I re-tested this in the 285 build and it seems to be working. Either I hadn't checked the option, or the code wasn't checked in when the last build was created.

I'm sending this to the beta testers.

g3ucq

2020-07-02 07:39

viewer   ~0009714

Fixed.

k2ie

2020-07-02 09:36

viewer   ~0009719

Tested with and without loopkup option checked, worked as expected in each case.

w4elp

2020-07-02 09:50

viewer   ~0009720

In 6.7.0.285 Beta, comment from previous QSO appears in Logbook ALE regardless of option setting. In DM780 ALE, comment from previous QSO does not appear, regardless of option setting.

w4elp

2020-07-02 09:57

viewer   ~0009721

Correction to previous note - After more checking and unchecking the option, it appears to be working correctly in Logbook ALE. Comment still does not appear in DM780 ALE regardless of option setting.

WA9PIE

2020-07-06 23:13

administrator   ~0009731

Doug - is it possible to take a look at DM-780 and see what it would take to make this same change happen in DM-780's ALE?

WA9PIE

2020-07-13 05:14

administrator   ~0009783

To update this one...

This does work properly in Logbook. That was the initial scope of this change.

That said, there is an ALE in DM-780 and customers will immediately tell us that this should also work in DM-780.

This makes me wonder if the either (a) the Comment field in DM-780 is different than the Comment field in Logbook or (b) we're using a different callsign lookup routine in DM-780 than we're using in Logbook.

@Will ask me if you have questions on this.

WA9PIE

2020-07-13 22:01

administrator   ~0009796

I just changed the Resolution from fixed to opened until we are able to take a look at the same topic in DM-780.

WILL

2020-07-15 18:07

developer   ~0009797

I just added this to the DM-780 code base. There is a new option in the logbook options to toggle adding the message to the ALE panel. It defaults to on like in the logbook.

g3ucq

2020-07-21 03:43

viewer   ~0009806

In DM780 comment pulled in from a previous QSO. Fixed

PD9FER

2020-07-21 05:01

viewer   ~0009810

Works for me.

WA9PIE

2020-07-21 05:02

administrator   ~0009811

Validated.

Issue History

Date Modified Username Field Change
2020-04-10 03:14 WA9PIE New Issue
2020-06-12 21:17 WA9PIE Assigned To => DOUG
2020-06-12 21:17 WA9PIE Status new => assigned
2020-06-12 21:17 WA9PIE Product Version => 67.0.280
2020-06-12 21:17 WA9PIE Testing Not Started => Alpha Failed
2020-06-12 21:17 WA9PIE Note Added: 0009689
2020-06-18 01:24 WA9PIE Product Version 67.0.280 => 6.7.0.282
2020-06-18 01:24 WA9PIE Note Added: 0009692
2020-06-18 14:43 WILL File Added: 3665_282.PNG
2020-06-18 14:43 WILL Note Added: 0009696
2020-07-02 07:16 WA9PIE Testing Alpha Failed => Not Started
2020-07-02 07:16 WA9PIE Note Added: 0009713
2020-07-02 07:17 WA9PIE Status assigned => resolved
2020-07-02 07:17 WA9PIE Resolution open => fixed
2020-07-02 07:17 WA9PIE Fixed in Version => 6.7.0.285
2020-07-02 07:39 g3ucq Note Added: 0009714
2020-07-02 09:36 k2ie Note Added: 0009719
2020-07-02 09:50 w4elp Note Added: 0009720
2020-07-02 09:57 w4elp Note Added: 0009721
2020-07-06 23:13 WA9PIE Note Added: 0009731
2020-07-11 22:10 DOUG Assigned To DOUG => WILL
2020-07-11 22:10 DOUG Status resolved => assigned
2020-07-13 05:14 WA9PIE Note Added: 0009783
2020-07-13 05:16 WA9PIE Product Version 6.7.0.282 => 6.7.0.290
2020-07-13 05:16 WA9PIE Fixed in Version 6.7.0.285 =>
2020-07-13 22:01 WA9PIE Resolution fixed => open
2020-07-13 22:01 WA9PIE Note Added: 0009796
2020-07-15 18:07 WILL Note Added: 0009797
2020-07-15 18:09 WILL Status assigned => resolved
2020-07-15 18:09 WILL Resolution open => fixed
2020-07-20 23:25 WA9PIE Fixed in Version => 6.7.0.294
2020-07-21 03:43 g3ucq Note Added: 0009806
2020-07-21 05:01 PD9FER Note Added: 0009810
2020-07-21 05:02 WA9PIE Status resolved => closed
2020-07-21 05:02 WA9PIE Testing Not Started => Beta Successful
2020-07-21 05:02 WA9PIE Note Added: 0009811
2020-07-21 05:12 WA9PIE Assigned To WILL => WA9PIE
2020-08-03 03:12 WA9PIE Fixed in Version 6.7.0.294 => 6.7.0.301
2020-08-03 03:14 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe