View Issue Details

IDProjectCategoryView StatusLast Update
0003689Ham Radio DeluxeBugpublic2020-08-03 03:14
ReporterWA9PIEAssigned ToWA9PIE 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version6.7.0.290 
Target VersionFixed in Version6.7.0.301 
Summary0003689: Cannot connect to DX cluster when the user has selected a callsign to use that contains a slash character
DescriptionNow that we have the ability to add callsigns for customers in QLM, we have requests for those callsigns to include a slash character. Examples include - VK4/WA9PIE, WA9PIE/M... and so on.

At present, the value used for connecting to the DX cluster comes from: Computer\HKEY_CURRENT_USER\Software\Amateur Radio\HRD User Profile\WA9PIE\Callsign (where WA9PIE is the station profile being used)

We need to change it so that the value used for connection to the DX cluster comes from: Computer\HKEY_CURRENT_USER\Software\Amateur Radio\HRD User Profile\WA9PIE\Operator
Steps To ReproduceUse a call that has a key assigned to it in QLM
Add a slash as an additional call
Attempt to connect to a DX cluster using the slash call as the active callsign
The DX cluster connection fails because they don't support slashes in the call
Additional InformationThis change will cause the Operator value to be sent to make the DX cluster connection, rather than the Callsign value. This will correct the problem.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleDX Cluster
Testing Beta Successful

Activities

WA9PIE

2020-06-03 22:03

administrator  

CHANGE-DXclusterCallsign.png (316,075 bytes)

WA9PIE

2020-07-02 07:04

administrator   ~0009712

Doug - can you take a look at this one?

WILL

2020-07-09 16:42

developer   ~0009739

I changed the get function in HRDStationLicense.cpp so it now gets the Operator value for DX cluster connections.

g3ucq

2020-07-13 04:05

viewer   ~0009769

EA6/***, /P and /M worked as they should.

WA9PIE

2020-07-13 04:09

administrator   ~0009770

@g3ucq John, try this with the VK4/G3UCQ callsign I just put in your key (the call shows up in My Station; select that "station" and connect to the cluster after it's selected.)

g3ucq

2020-07-13 04:21

viewer   ~0009771

Mike. /M, /P, /8 work OK with my new callsign.

WA9PIE

2020-07-13 04:47

administrator   ~0009776

This isn't working correctly. I'll need to capture the steps and add them to this item later. (We can't release it the way it is.)

WA9PIE

2020-07-13 08:42

administrator   ~0009786

@WILL

I've recorded a video here. The free recording software I used limited me to 5 minutes. It cut off with about 15 seconds left. I hope there's enough in these examples to give you an idea about how it should work. Let me know if you have any questions.

https://wa9pie.tinytake.com/tt/NDQ1MDMyNV8xNDA3NjU2Mw

g3ucq

2020-07-13 08:56

viewer   ~0009787

I did not get the window pop up that you see Mike.
VK4/G3UCQ is the same as your example.

WA9PIE

2020-07-13 09:04

administrator   ~0009788

In this scenario, you would only get the popup if you had selected VK4/G3UCQ as the active call. Pardon me for asking, but you did that? (sorry, just checking)

g3ucq

2020-07-13 09:20

viewer   ~0009789

Mike
I have added HRD test.mp4 to the Dropbox/Ham Radio Deluxe(1)/HRD Beta Team folder
Hope this helps.

WILL

2020-07-13 12:51

developer   ~0009790

It looks like those fields weren't using the same get functions as the actual connect function. I updated it so that they use the same functions. I also set the user info to update after you exit the my station dialog so if your in your connection menu you don't have to close and reopen for it to have your changes. My station kept popping up in your video because your locator option wasn't filled in. We probably want to add an error dialog or something similar to let the user know there is missing required info.

WA9PIE

2020-07-13 18:10

administrator   ~0009791

@WILL Agreed on the error dialog. We can pick that up whenever. Thanks.

g3ucq

2020-07-21 03:53

viewer   ~0009807

Fixed for me.

WA9PIE

2020-07-21 05:11

administrator   ~0009812

Validated

Issue History

Date Modified Username Field Change
2020-06-03 17:20 WA9PIE New Issue
2020-06-03 22:02 WA9PIE Assigned To => DOUG
2020-06-03 22:02 WA9PIE Status new => assigned
2020-06-03 22:02 WA9PIE Description Updated View Revisions
2020-06-03 22:02 WA9PIE Steps to Reproduce Updated View Revisions
2020-06-03 22:02 WA9PIE Additional Information Updated View Revisions
2020-06-03 22:02 WA9PIE Module (select) => Logbook
2020-06-03 22:02 WA9PIE Sub-Module (select) => DX Cluster
2020-06-03 22:03 WA9PIE File Added: CHANGE-DXclusterCallsign.png
2020-07-02 07:04 WA9PIE Note Added: 0009712
2020-07-09 14:10 WILL Assigned To DOUG => WILL
2020-07-09 16:42 WILL Note Added: 0009739
2020-07-09 16:43 WILL Status assigned => resolved
2020-07-09 16:43 WILL Resolution open => fixed
2020-07-12 20:25 WA9PIE Fixed in Version => 6.7.0.290
2020-07-13 04:05 g3ucq Note Added: 0009769
2020-07-13 04:09 WA9PIE Note Added: 0009770
2020-07-13 04:21 g3ucq Note Added: 0009771
2020-07-13 04:47 WA9PIE Status resolved => assigned
2020-07-13 04:47 WA9PIE Resolution fixed => reopened
2020-07-13 04:47 WA9PIE Product Version => 6.7.0.290
2020-07-13 04:47 WA9PIE Fixed in Version 6.7.0.290 =>
2020-07-13 04:47 WA9PIE Testing Not Started => Beta Failed
2020-07-13 04:47 WA9PIE Note Added: 0009776
2020-07-13 08:42 WA9PIE Note Added: 0009786
2020-07-13 08:56 g3ucq Note Added: 0009787
2020-07-13 09:04 WA9PIE Note Added: 0009788
2020-07-13 09:20 g3ucq Note Added: 0009789
2020-07-13 12:51 WILL Note Added: 0009790
2020-07-13 12:55 WILL Status assigned => resolved
2020-07-13 12:55 WILL Resolution reopened => fixed
2020-07-13 18:10 WA9PIE Note Added: 0009791
2020-07-20 23:25 WA9PIE Fixed in Version => 6.7.0.294
2020-07-21 03:53 g3ucq Note Added: 0009807
2020-07-21 05:11 WA9PIE Status resolved => closed
2020-07-21 05:11 WA9PIE Testing Beta Failed => Beta Successful
2020-07-21 05:11 WA9PIE Note Added: 0009812
2020-07-21 05:12 WA9PIE Assigned To WILL => WA9PIE
2020-08-03 03:12 WA9PIE Fixed in Version 6.7.0.294 => 6.7.0.301
2020-08-03 03:14 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe