View Issue Details

IDProjectCategoryView StatusLast Update
00036923 - Current Dev ListBugpublic2020-07-06 23:09
ReporterWA9PIEAssigned ToDOUG 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version67.0.280 
Target VersionFixed in Version6.7.0.285 
Summary0003692: Order of callsign lookup methods are not saved when re-ordering them in "Enabled Methods"
DescriptionI hope this won't get too confusing. There was some debate about how the "Enabled Methods" are displayed. So I'll give some context in a moment.

But the problem here is that with the 6.7.0.280 build - if you try to re-order the enabled methods (the ones that are allowed to be re-ordered), they do not retain the order when you save them (by clicking Ok or Apply).
Steps To Reproduce- open Logbook
- go to the Callsign Lookup options page (Tools > Callsign Lookup > Enable tab)
NOTE: By design, the Public and Private UCSDB are permanently pinned to the top. The Country List is permanently pinned to the bottom. This cannot be changed without affecting the accuracy of the callsign lookup feature. The only methods that be enabled are the optional ones that can be added from the list on the right.
- Add two or more of the Disabled Methods on the right into the Enabled Methods on the left. Change the order.
- Click "OK" to save and exit.
- go to the Callsign Lookup options page (Tools > Callsign Lookup > Enable tab)
- observe the order of the methods; is this what you saved?
- change the order again
- Click "OK" to save and exit
- go to the Callsign Lookup options page (Tools > Callsign Lookup > Enable tab)
- observe the order of the methods; is this what you saved?
Additional InformationBecause of this, we should re-test all the Callsign Lookup scenarios to make sure that the feature is working as-designed.

We can't release with this.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
Testing Beta Successful

Activities

WA9PIE

2020-06-17 22:28

administrator   ~0009691

Confirmed fixed in 6.7.0.282

g3ucq

2020-07-02 04:46

updater   ~0009709

Fixed.

WA9PIE

2020-07-06 23:09

administrator   ~0009728

Validated by beta testers; marking as Closed

Issue History

Date Modified Username Field Change
2020-06-12 21:28 WA9PIE New Issue
2020-06-12 21:29 WA9PIE Assigned To => DOUG
2020-06-12 21:29 WA9PIE Status new => assigned
2020-06-12 21:29 WA9PIE Additional Information Updated View Revisions
2020-06-17 22:28 WA9PIE Status assigned => resolved
2020-06-17 22:28 WA9PIE Resolution open => fixed
2020-06-17 22:28 WA9PIE Product Version => 67.0.280
2020-06-17 22:28 WA9PIE Fixed in Version => 6.7.0.282
2020-06-17 22:28 WA9PIE Testing Not Started => Alpha Successful
2020-06-17 22:28 WA9PIE Note Added: 0009691
2020-07-02 01:11 WA9PIE Fixed in Version 6.7.0.282 => 6.7.0.285
2020-07-02 04:46 g3ucq Note Added: 0009709
2020-07-06 23:09 WA9PIE Status resolved => closed
2020-07-06 23:09 WA9PIE Testing Alpha Successful => Beta Successful
2020-07-06 23:09 WA9PIE Note Added: 0009728