View Issue Details

IDProjectCategoryView StatusLast Update
0003695Ham Radio DeluxeBugpublic2020-08-03 03:14
ReporterWA9PIEAssigned ToWA9PIE 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.7.0.301 
Summary0003695: Additional callsigns with prefix that do not contain a number are not showing in My Station
DescriptionWith the implementation of QLM, we are able to add additional callsigns to a key through "Product Properties." When additional callsigns are added into Product Properties for a given key, they are added as text separated by commas.

Some additional callsigns have a "prefix". This is the text that precedes the callsign before a slash. For example:

WA9PIE is a callsign
TI4/WA9PIE is a callsign with a prefix

When the prefix contains a number ("TI4"), this feature works perfectly.

When the prefix does not contain a number ("TI"), the feature does not work.

We believe that this is a limitation imposed via code in our software. (ie. The problem is not in QLM.)
Steps To Reproduce> Go into QLM for a given key (your personal key or a test key).
> Edit your key
> Go to the "Product Properties" tab
> Enter "TI4/WA9PIE" into the field; launch Logbook; observe the "TI4/WA9PIE" tab in Logbook's My Station (Tools > Configure > My Station); this works
> Change the additional callsign to drop the "4" so it reads "TI/WA9PIE"; observe that the call does not appear in Logbook's My Station
TagsNo tags attached.
ModuleLogbook
Sub-ModuleData
Testing Beta Successful

Activities

WA9PIE

2020-07-02 07:04

administrator   ~0009711

Doug - can you take a look at this one?

WA9PIE

2020-07-13 05:08

administrator   ~0009782

Most of you won't be able to test this because you won't have additional slash calls (without numbers) in your key.

I did test this and it's good.

Validated.

Issue History

Date Modified Username Field Change
2020-06-21 18:46 WA9PIE New Issue
2020-06-21 18:46 WA9PIE Status new => assigned
2020-06-21 18:46 WA9PIE Assigned To => DOUG
2020-07-02 07:04 WA9PIE Note Added: 0009711
2020-07-11 22:06 DOUG Status assigned => resolved
2020-07-11 22:06 DOUG Resolution open => fixed
2020-07-11 22:06 DOUG Fixed in Version => 6.7.0.287
2020-07-12 20:25 WA9PIE Fixed in Version 6.7.0.287 => 6.7.0.290
2020-07-13 05:08 WA9PIE Status resolved => closed
2020-07-13 05:08 WA9PIE Testing Not Started => Beta Successful
2020-07-13 05:08 WA9PIE Note Added: 0009782
2020-07-21 05:12 WA9PIE Assigned To DOUG => WA9PIE
2020-08-03 03:12 WA9PIE Fixed in Version 6.7.0.290 => 6.7.0.301
2020-08-03 03:14 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe