View Issue Details

IDProjectCategoryView StatusLast Update
0000529Ham Radio DeluxeBugpublic2017-05-24 21:44
ReporterW4PC 
Assigned ToW4PC 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformIntel PCOSWindows 7OS VersionUltimate SP1
Product Version 
Target VersionFixed in Version6.2.4 
Summary0000529: HRD 'K1EL Winkey' Crashes after selecting 'Track speed pot'
DescriptionUsing the HRD 'K1EL Winkey' tool, asking to track the speed control on the keyer causes program crashes or disconnnects from Winkey. Sometimes it fails holding the transmitter on.
Steps To Reproducewith Winkeyer connected:

Start HRD
Select Tools->K1EL Winkey
Select F8 to get to the options window
Select 'Speed' tab.
check 'Track speed pot'
adjust the speed control on the winkeyer
observe disconnects or program crash or transmit enabled
Additional InformationIf the speed control isn't moved, fault doesn't seem to occur.
Generally, if not crashed, disconnect and reconnect from the 'Keyer' tab under F8 options and operation is restored (if lucky).
TagsNo tags attached.
ModuleRig Control
Sub-ModuleWinkeyer
Testing

Relationships

Activities

W4PC

2014-01-28 18:46

updater   ~0000160

Winkey is only supported in DM780 not in HRD.. that was leftover from v 4 and is no longer supported by HRD.

Winkeyer in HRD works fine with the issue above

WA9PIE

2014-03-25 17:00

administrator   ~0000384

Looks like we removed it from the Rig Control screen.

Problem solved.

WA9PIE

2014-03-25 17:00

administrator   ~0000385

Removed from Rig Control.

Problem Solved.

Issue History

Date Modified Username Field Change
2013-12-21 18:56 W4PC New Issue
2013-12-21 18:56 W4PC Assigned To => W4PC
2013-12-21 18:57 W4PC Project 2 - Next Dev List (Holding Area) => @5@
2014-01-28 18:46 W4PC Note Added: 0000160
2014-01-28 18:46 W4PC Release => (select)
2014-01-28 18:46 W4PC Fix Build => 6.1.189
2014-01-28 18:46 W4PC Module => (select)
2014-01-28 18:46 W4PC Sub-Module => (select)
2014-01-28 18:46 W4PC Report Build => (select)
2014-01-28 18:46 W4PC Status assigned => resolved
2014-01-28 18:46 W4PC Resolution open => fixed
2014-02-02 14:41 WA9PIE Summary HRD 'K1EL Winkey' Crashes after selecting 'Track speed pot' => Bug: HRD 'K1EL Winkey' Crashes after selecting 'Track speed pot'
2014-02-02 16:42 WA9PIE Project @5@ => 3 - Current Dev List
2014-03-25 17:00 WA9PIE Note Added: 0000384
2014-03-25 17:00 WA9PIE Module (select) => Rig Control
2014-03-25 17:00 WA9PIE Sub-Module (select) => Winkeyer
2014-03-25 17:00 WA9PIE Report Build (select) => 6.1.4.189
2014-03-25 17:00 WA9PIE Note Added: 0000385
2014-03-25 17:00 WA9PIE Status resolved => closed
2014-10-08 22:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2014-10-08 22:13 WA9PIE Category Rig Control => General
2015-09-30 11:40 WA9PIE Fix Build 6.1.189 => (select)
2015-09-30 11:40 WA9PIE Proposed Release => TBD
2015-09-30 11:40 WA9PIE Summary Bug: HRD 'K1EL Winkey' Crashes after selecting 'Track speed pot' => HRD 'K1EL Winkey' Crashes after selecting 'Track speed pot'
2015-09-30 13:33 WA9PIE Category General => Bug
2017-05-22 00:02 WA9PIE Sticky Issue Yes => No
2017-05-24 21:44 WA9PIE Fixed in Version => 6.2.4
2017-05-24 21:44 WA9PIE Reported in Build (ie. 377) 6.1.4.189 => 189
2017-05-24 21:44 WA9PIE Fixed in Build (ie. 377) (select) =>