View Issue Details

IDProjectCategoryView StatusLast Update
0000538Ham Radio DeluxeBugpublic2017-06-19 19:47
ReporterW4PC 
Assigned ToWA9PIE 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platform386OSWindowsOS Version7
Product Version 
Target VersionFixed in Version6.2.4 
Summary0000538: Logbook ALE textbox incorrect behaviour
DescriptionThis problem occurs if the QRZ.com subscription or the Callbook.info options have looked up a call. Problem does not occur if logbook or country list is used for lookup.

Steps To ReproduceStart the logbook application and open the logbook ALE window.

 Type a valid call sign in the ALE Call textbox.

 Move mouse pointer to the Received Exchange textbox (to the left of the RST Received box)and left click ONCE.

 Note that the edit cursor begins to flash at the left side of the Received Exchange textbox and that the mouse cursor changes to a text edit cursor.

 Type a character. Note that it does NOT appear in the Received Exchange textbox even though that box seems to have the focus.

 Left click the mouse one more time. Note that the mouse cursor changes to the select arrow cursor. Type a character and note that it appears in the textbox as expected. So it takes two left clicks to enter info into the textbox.
Additional InformationIf you reset the ALE window and enter the same call again, characters will enter the Received Exchange box after that box is left clicked once. (Normal behavior) In that case I believe the call sign data has been retrieved from a cache of recent lookups instead of a QRZ.com or Callbook.info lookup.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleALE Window
Testing

Relationships

Activities

user10

2014-01-29 08:36

  ~0000173

This also seems to be resolved. When I left click once, it will add whatever I type in.

WA9PIE

2014-02-02 19:54

administrator   ~0000328

What I'm seeing is that - if you don't have the "Default lookup data" checkbox checked... you don't get any lookup data if you just click in another box.

People will complain about that.

We need to populate country whenever someone leaves the Call field.

WA9PIE

2014-02-03 23:45

administrator   ~0000338

Rick and I both tried this successfully.

WA9PIE

2014-03-24 23:30

administrator   ~0000375

The bigger problem is this...

When you enter a valid call... and then click in another box (rather than tab), it DOES NOT fill the fields (do the callsign lookup). It should.

WA9PIE

2014-05-01 22:46

administrator   ~0000416

I tried this and it seems to be working now. I never saw the problem originally. But running through the steps outlined, I can't find the same problem.

Issue History

Date Modified Username Field Change
2013-12-21 18:56 W4PC New Issue
2013-12-21 18:58 W4PC Project 2 - Next Dev List (Holding Area) => @5@
2014-01-29 00:48 WA9PIE Project @5@ => 3 - Current Dev List
2014-01-29 08:36 user10 Note Added: 0000173
2014-02-02 15:25 WA9PIE Release => (select)
2014-02-02 15:25 WA9PIE Module => (select)
2014-02-02 15:25 WA9PIE Sub-Module => (select)
2014-02-02 15:25 WA9PIE Report Build => (select)
2014-02-02 15:25 WA9PIE Status new => acknowledged
2014-02-02 15:25 WA9PIE Summary Logbook ALE textbox incorrect behaviour => Bug: Logbook ALE textbox incorrect behaviour
2014-02-02 19:54 WA9PIE Note Added: 0000328
2014-02-03 23:44 WA9PIE Severity text => minor
2014-02-03 23:45 WA9PIE Release (select) => 6.1
2014-02-03 23:45 WA9PIE Fix Build => 6.2.213+ alpha build
2014-02-03 23:45 WA9PIE Module (select) => Logbook
2014-02-03 23:45 WA9PIE Sub-Module (select) => ALE Window
2014-02-03 23:45 WA9PIE Report Build (select) => 6.1.4.189
2014-02-03 23:45 WA9PIE Note Added: 0000338
2014-02-03 23:45 WA9PIE Status acknowledged => resolved
2014-02-03 23:45 WA9PIE Resolution open => fixed
2014-02-03 23:45 WA9PIE Assigned To => WA9PIE
2014-03-24 23:30 WA9PIE Note Added: 0000375
2014-03-24 23:30 WA9PIE Status resolved => assigned
2014-05-01 22:46 WA9PIE Note Added: 0000416
2014-05-01 22:46 WA9PIE Status assigned => closed
2014-10-08 22:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2014-10-08 22:13 WA9PIE Category Logbook => General
2015-09-30 12:33 WA9PIE Fix Build 6.2.213+ alpha build => (select)
2015-09-30 12:33 WA9PIE Proposed Release => TBD
2015-09-30 12:33 WA9PIE Summary Bug: Logbook ALE textbox incorrect behaviour => Logbook ALE textbox incorrect behaviour
2015-09-30 13:35 WA9PIE Category General => Bug
2017-06-19 19:47 WA9PIE Fixed in Version => 6.2.4