View Issue Details

IDProjectCategoryView StatusLast Update
0000548Ham Radio DeluxeBugpublic2017-06-19 19:49
ReporterW4PC 
Assigned ToWA9PIE 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMicrosoftOSWindowsOS Version7
Product Version 
Target VersionFixed in Version6.2.4 
Summary0000548: Heading in dx cluster window often wrong (sometimes shows 180 degrees for stations without location data)
DescriptionIn the cluster window, the "headings" option doesn't work. This happens all the time.
Steps To Reproduceconstant
TagsNo tags attached.
ModuleLogbook
Sub-ModuleDX Cluster
Testing

Relationships

Activities

WA9PIE

2014-01-19 22:06

administrator   ~0000119

Cluster Heading and Distance

ATTENTION: I have figured out what's causing this and I know how we're going to fix it. Please read.

Dani sent me a screenshot of a Chilean station (CE2/CX1EK) that was showing 180 degrees from Israel. So I went in and did a "sh/dx/1 CE2/CX1EK" so that I could compare to my location. I also saw 180 degrees. WHAT?

Then I looked at the string received by the cluster node (WA9PIE-2 a DX Spider node). What I found is this:

DX Spider and CC Cluster have a field in the CC11 string for "DX Locator" (grid). But in the spot for "CE2/CX1EK", that field was EMPTY.

Therefore...

Distance and Heading are being calculated based on the grid conveyed in the "DX Locator" position in the spot. That is - it's the distance and heading between YOUR grid and the spotted station's grid. And...

When the "DX Locator" field is empty in the spot, then it defaults to THE SOUTH POLE. That's why both Dani and I were 180 degrees from this station (and over 8,000 miles).

Here's how we're going to fix it.

When the "DX Locator" field in the spot is empty (or in AR Cluster, doesn't exist), we're going to fill the Distance and Heading with "N/A".

This is consistent with the approach that we're taking for all cluster changes. That is...

Because some CC11 strings have empty fields, and because AR17 and CC11 have different content, there will be cases where certain fields are missing. Examples include "DX State", "Spotter State", "DX Grid", and "Spotter Grid"... and fields calculated by any of those... will get a "N/A" instead of being blank.

The logic behind this is that we'd rather show people that the 'data doesn't exist', than show it blank or with bad data... which might leave folks thinking that HRD has made a mistake or has a bug.

WA9PIE

2014-01-19 23:40

administrator   ~0000125

All these are pending the 6.2 release.

WA9PIE

2014-02-03 22:26

administrator  

Heading wrong.JPG (318,430 bytes)

WA9PIE

2014-02-04 22:00

administrator  

Heading wrong-01.JPG (309,340 bytes)

WA9PIE

2014-02-05 22:31

administrator   ~0000347

I believe what's happening is that the callsign is being parsed to determine the country... to determine the coordinates from the default location in the country file or matching to a zip code or something.

But when we don't have a zip code to go on, we should really avoid parsing the callsign to determine location and simply take the Country provided by the cluster (DX Country field) and use THAT as the lookup against the country file (rather than the call).

WA9PIE

2014-02-26 18:25

administrator   ~0000361

I tested this and it looks good.

WA9PIE

2014-03-24 23:10

administrator   ~0000369

Tried it and I no longer see errors.

Mike, wa9pie

Issue History

Date Modified Username Field Change
2013-12-21 18:56 W4PC New Issue
2013-12-21 18:57 W4PC Project 2 - Next Dev List (Holding Area) => @5@
2014-01-19 13:24 WA9PIE Project @5@ => 3 - Current Dev List
2014-01-19 22:06 WA9PIE Note Added: 0000119
2014-01-19 23:40 WA9PIE Status new => acknowledged
2014-01-19 23:40 WA9PIE Note Added: 0000125
2014-01-19 23:42 WA9PIE Status acknowledged => assigned
2014-01-19 23:42 WA9PIE Assigned To => WA9PIE
2014-02-02 15:30 WA9PIE Release => (select)
2014-02-02 15:30 WA9PIE Module => (select)
2014-02-02 15:30 WA9PIE Sub-Module => (select)
2014-02-02 15:30 WA9PIE Report Build => (select)
2014-02-02 15:30 WA9PIE Summary "heading" function in dx cluster window doesn't work => 180 degree on the rotor"heading" function in dx cluster window doesn't work
2014-02-02 15:57 WA9PIE Summary 180 degree on the rotor"heading" function in dx cluster window doesn't work => Bug: 180 degree on the rotor"heading" function in dx cluster window doesn't work
2014-02-03 22:26 WA9PIE File Added: Heading wrong.JPG
2014-02-04 22:00 WA9PIE File Added: Heading wrong-01.JPG
2014-02-05 21:52 WA9PIE Summary Bug: 180 degree on the rotor"heading" function in dx cluster window doesn't work => Bug: heading in dx cluster window often wrong (sometimes shows 180 degrees for stations without location data)
2014-02-05 22:31 WA9PIE Note Added: 0000347
2014-02-26 18:25 WA9PIE Release (select) => 6.1
2014-02-26 18:25 WA9PIE Fix Build => 6.2.3.229
2014-02-26 18:25 WA9PIE Module (select) => Logbook
2014-02-26 18:25 WA9PIE Sub-Module (select) => DX Cluster
2014-02-26 18:25 WA9PIE Report Build (select) => 6.1.4.189
2014-02-26 18:25 WA9PIE Note Added: 0000361
2014-02-26 18:25 WA9PIE Status assigned => resolved
2014-02-26 18:25 WA9PIE Resolution open => fixed
2014-03-24 23:10 WA9PIE Note Added: 0000369
2014-03-24 23:10 WA9PIE Status resolved => closed
2014-10-08 22:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2014-10-08 22:13 WA9PIE Category Logbook => General
2015-09-30 12:04 WA9PIE Fix Build 6.2.3.229 => (select)
2015-09-30 12:04 WA9PIE Proposed Release => TBD
2015-09-30 12:04 WA9PIE Summary Bug: heading in dx cluster window often wrong (sometimes shows 180 degrees for stations without location data) => Heading in dx cluster window often wrong (sometimes shows 180 degrees for stations without location data)
2015-09-30 13:35 WA9PIE Category General => Bug
2017-06-19 19:49 WA9PIE Fixed in Version => 6.2.4