View Issue Details

IDProjectCategoryView StatusLast Update
0000557Ham Radio DeluxeBugpublic2019-02-24 15:13
ReporterW4PCAssigned ToJOSE 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformAcer V5-471 (w/8GB RAM)OSWindows 8 (64 bit)OS VersionPro
Product Version 
Target VersionFixed in Version6.5.0.196 
Summary0000557: HRD Rotator unable to reconnect to correct COM port after disconnect
DescriptionAfter successfully connecting and communicating with external rotator controller device via USB-COM port, if the computer hibernates, sleeps, or the connecting cable is unplugged and plugged back in, HRD Rotator is unable to reconnect to the COM port in use by the rotator controller device. The correct COM port is installed & displayed within Windows Device Manager, and is still correctly specified within the HRD Rotator Configuration preset profile (Tools-Options-Configuration tab). However, the "Serial Port" drop-down list for the rotator in the main HRD Rotator screen does not show the correct COM port required for connection. Terminating HRD Rotator, or Rig Control, and restarting the applications does NOT resolve the problem. An OS restart is required to correct the problem. Other applications being used on my machine do not have this problem, and are able to reconnect to the COM port when restored by Windows (eg, Serial Port Monitor utility, Arduino IDE, Terminal, etc).
Steps To Reproduce(1) Connect rotator controller device (Yaesu model GS232B in my configuration) to computer USB port via USB-serial adapter cable (FTDI chipset based cable adapter connection used in my configuration). First time when plugging in the USB cable will cause Windows 8 to install a WHQL FTDI driver already contained in Windows (in most instances).
 (2) Since HRD Rotator does not auto-detect its COM port (!), open Windows Device Manager, selected Hardware Devices, select Ports, and determine which COM port number is used by the rotator controller device (COM9 in my configuration is used).
 (3) Configure HRD Rotator...Protocol: GS232B Az-El, Serial Port: COM9 (or whatever is the correct one found in Device Manager), Speed: 9600, Update: 1 second (or 2secs); I named my configuration preset profile "G5500" to reflect the model Yaesu G-5500 az-el rotator being used (& controlled by the GS232B controller).
(4) Click on "Connect" button; HRD Rotator will connect to the external rotator controller and begin communicating with it. The "Logfile" tab should then begin showing the series of sent & received data with the rotator controller device, beginning with serial port configuration.
(5) When satisfied that HRD Rotator is communicating with the rotator controller device, interrupt its operation by unplugging the USB connecting cable going from the computer to the rotator controller. Windows will subsequently uninstall the specific COM port (COM9 in my configuration), which can be confirmed using Windows Device Manager. Unplugging the connecting cable is a faster means of inducing the problem as compared to putting the computer into sleep or hibernate modes and re-awakening the computer.
(6) Replug the USB connecting cable into the same physical USB port used previously on the computer. Windows will subsequently reinstall the same COM port (COM9 in my configuration), which can be confirmed by viewing Windows Device Manager.
(7) Notice that HRD Rotator's main screen settings for the rotator controller no longer shows the correct COM port setting for "Serial Port"; click on that drop-down list and the correct COM port for the controller is MISSING in the list (in my configuration ONLY the COM11 port for the HRD Rig Control program connection to the radio is displayed in the list).
(8) Clicking on "Connect" in the Rotator main screen fails (of course).
(9) Select Tools-Options-Configuration, and note that the preset profile for the rotator device (named G5500 in my configuration to reflect the Yaesu model G-5500 az-el rotator being used) STILL shows the correct COM port (COM9 in my configuration) required for connecting to the rotator controller. This preset profile is apparently not being read by HRD Rotator and used when attempting to connect during this problem.
(10) Double-click on the appropriate preset Configuration profile in the list containing the required COM port number, OR select it in the list and click on "Modify", and an edit dialog will open for that preset profile. Notice that now the drop-down list for the Serial port does not show the required COM port...it is missing now similar to what we saw on the main Rotator display screen.
(11) Terminate and Restart all HRD programs (Rig Control, Rotator, etc). The problem persists in Rotator, despite HRD Rig Control successfully connecting to its radio COM port.
(12) Restart Windows to recover.
Additional InformationTim kb3nph of HRD Support witnessed this problem during a remote control session on Tue 8 Oct 2013.

Arduino IDE had a similar problem only with Windows 8, but fixed it during early 2013.

HRD Rig Control program has not been tested yet for the same problem, but I surely would have noticed it if Rig Control also failed to reconnect after computer sleep/hibernation; ie, the problem may be isolated to Rotator's handling of COM ports but I cannot testify/confirm that yet.

Windows 8 has a different, albeit more secure, device driver framework that affects device drivers, may be part of the root cause and may require a compatibility update with applications such as HRD.
TagsNo tags attached.
ModuleRotator
Sub-Module(select)
Testing Beta Successful

Activities

JOSE

2019-02-12 20:59

developer   ~0007361

Program now registers to windows to be notify of any serial port changes.

WA9PIE

2019-02-21 09:39

administrator   ~0007474

Validated.

I ran through the steps. I did find that - once I reconnected the USB cable - I had to click "Disconnect" and then "Connect" again. But that's not a problem... and the problem reported has been eliminated.

Issue History

Date Modified Username Field Change
2013-12-21 18:56 W4PC New Issue
2013-12-21 18:57 W4PC Project 2 - Next Dev List (Holding Area) => @5@
2014-01-31 22:56 WA9PIE Release => (select)
2014-01-31 22:56 WA9PIE Module => (select)
2014-01-31 22:56 WA9PIE Sub-Module => (select)
2014-01-31 22:56 WA9PIE Report Build => (select)
2014-01-31 22:56 WA9PIE Status new => acknowledged
2014-02-02 14:45 WA9PIE Summary HRD Rotator unable to reconnect to correct COM port after disconnect => Bug: HRD Rotator unable to reconnect to correct COM port after disconnect
2015-09-17 13:09 WA9PIE Module (select) => Rotator
2015-09-17 13:15 WA9PIE Category Rotator => Bug
2015-09-17 13:19 WA9PIE Project @5@ => 1 - Backlog
2015-09-29 16:07 WA9PIE Fix Build => (select)
2015-09-29 16:07 WA9PIE Summary Bug: HRD Rotator unable to reconnect to correct COM port after disconnect => HRD Rotator unable to reconnect to correct COM port after disconnect
2018-03-04 00:53 WA9PIE Status acknowledged => assigned
2018-03-04 00:53 WA9PIE Assigned To => JOSE
2018-03-04 00:54 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-03-04 00:56 WA9PIE Testing => Not Started
2019-02-12 20:59 JOSE Status assigned => resolved
2019-02-12 20:59 JOSE Resolution open => fixed
2019-02-12 20:59 JOSE Fixed in Version => 6.5.0.192
2019-02-12 20:59 JOSE Note Added: 0007361
2019-02-21 09:39 WA9PIE Status resolved => closed
2019-02-21 09:39 WA9PIE Testing Not Started => Beta Successful
2019-02-21 09:39 WA9PIE Note Added: 0007474
2019-02-24 14:36 WA9PIE Fixed in Version 6.5.0.192 => 6.5.0.196
2019-02-24 15:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe