View Issue Details

IDProjectCategoryView StatusLast Update
0000560Ham Radio DeluxeBugpublic2019-11-08 02:32
ReporterW4PCAssigned ToPD9FER 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformAcer V5-471 (w/8GB RAM)OSWindows 8 (64 bit)OS VersionPro
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0000560: HRD Rotator incompatible with Azimuth & Elevation range of Yaesu model G-5500 rotator
DescriptionHRD Rotator does not currently support 450 degree azimuth range of the Yaesu model G-5500 azimuth rotator. The maximum azimuth range choice currently provided in HRD Rotator presently is 360 degrees ("stop" at North); a maximum "stop" at 450 degrees East is needed. Also, HRD Rotator does not currently support 180 degree elevation range of the Yaesu G-5500 elevation rotator. The maximum elevation range setting found in HRD Rotator presently is 90 degrees; a maximum range choice of 180 degrees is needed in the rotator configuration.

This prevents proper operation of HRD Rotator when using SatTrack with Yaesu G-5500 rotators for those instances where satellite paths move outside the HRD Rotator path limits of 360 deg azimuth & 90 deg elevation, and where otherwise a loss of communications with the satellite results from the rotator swinging azimuth back around to pick up an elevation track that is interrupted.

HRD Rotator Logfile tab does show current elevation position values that exceed 90 degrees being received from the GS232B rotator controller device, but those values do not seem to be used by HRD Rotator or HRD Satellite Tracking, which is required to avoid loss of satellite position tracking and therefore radio communications with satellites whose path requires azimuth beginning <360 deg and ending >90 deg values.

Note that increasing the elevation range in HRD Rotator will require a change in the displayed elevation gauge in both Rotator and SatTrack to display 180 degrees. Note also that increasing the azimuth range in HRD Rotator should also require the displayed azimuth gauge in both Rotator and SatTrack to display 450 degrees via an "overlap" area marked adjacent to the 0-90 degree scale.
Steps To Reproduce(1) Connect any computer using either standard DB9 serial COM port, or USB-serial adapter cable, to a Yaesu GS232A or GS232B rotator (or emulator) device that is in turn connected to a Yaesu model G-5500 az-el antenna rotator.
(2) Configure HRD Rotator settings for Protocol= GS232A Az-El or GS232B Az-El.
(3) Make sure that "Gauges" are turned on/displayed in Rotator's main screen (button on right, display on left pane).
(4) Select "Stop Position" setting drop-down list; notice there is no choice displayed for 450 degrees East to match the capabilities of the Yaesu G-5500 rotator.
(5) Notice there is no configuration selection displayed anywhere for 180 degree elevation range for elevation rotator control. My recommendation is that a "Elevation Stop Position" be added to the rotator settings (including the preset profiles in Tools-Options-Configuration), and that the present "Stop Position setting drop-down list be renamed to "Azimuth Stop Position".
Additional InformationTim kb3nph of HRD Support witnessed this during a remote control support session on Tue 8 Oct 2013.

The Yaesu G-5500 is the most popular antenna rotator (marketshare and installed base) for satellite tracking applications. It is also a popular rotator for EME (moon bounce), meteor scatter, APRS-GPS balloon tracking, and other az-el applications.

It is likely IMO that there are several other make/model antenna rotators in the market capable of 180 degrees elevation range and >360 degree azimuth range, besides the popular Yaesu G-5500 rotator, as such range requirements would be common for satellite & other sky object tracking.

I have read a report on an internet forum that this same problem prevents full compatibility of HRD with the Yaesu model G-5400 rotator. I cannot confirm, as I do not possess a G-5400.
TagsNo tags attached.
ModuleRotator
Sub-Module(select)
TestingNot Started

Activities

user19

2014-01-31 20:32

  ~0000277

I have a G-5400 and can confirm the limitation. Jim

ag6hq

2015-10-12 13:03

viewer   ~0000641

The Yaesu G-800DXA, ‎G-1000DXA and the G-2800DXA rotors all have 450° rotation, and all can be controlled by a Yaesu and other brands of interfaces.

WA9PIE

2019-02-26 18:08

administrator   ~0007516

I understand the point here... but I don't think it's a big problem. We'll keep this on the list, but may decide we've got it covered by other methods.

PD9FER

2019-09-01 02:51

viewer   ~0008483

Got another one asking for a fix Ticket 831417

WA9PIE

2019-09-07 08:44

administrator   ~0008522

Ferry - give the beta to the customer and see if he can validate it.

PD9FER

2019-09-08 02:37

viewer   ~0008539

Beta given to customer, awaiting reply.

WA9PIE

2019-09-13 23:42

administrator   ~0008544

That was five days ago. Do we have an update?

g3ucq

2019-09-23 05:57

viewer   ~0008599

Unable to test

PD9FER

2019-09-23 13:28

viewer   ~0008613

No info as is

WA9PIE

2019-09-24 00:16

administrator   ~0008626

Ferry, please try to gather info. I won't be holding the release for the validation of this one.

PD9FER

2019-10-16 07:54

viewer   ~0008828

Sorry, customer won't reply

PD9FER

2019-10-17 14:08

viewer   ~0008845

Customer uses an arduino.
This is not a supported device, but just emulates it.

This should be closed

KB3NPH

2019-10-17 14:16

administrator   ~0008846

Since this is based on R3 ARDUINO we can't support it since it's a homebrewed controller emulating the GS-232A/B controller. Closing this issue.

WA9PIE

2019-10-28 16:31

administrator   ~0009040

This is not unique to any Arduino hardware. I've spoken to customers who have reported this as well. We'll get it tested at some point. I'm not holding the release for validating this.

Issue History

Date Modified Username Field Change
2013-12-21 18:56 W4PC New Issue
2013-12-21 18:57 W4PC Project 2 - Next Dev List (Holding Area) => @5@
2014-01-31 20:32 user19 Note Added: 0000277
2014-01-31 22:53 WA9PIE Release => (select)
2014-01-31 22:53 WA9PIE Module => (select)
2014-01-31 22:53 WA9PIE Sub-Module => (select)
2014-01-31 22:53 WA9PIE Report Build => (select)
2014-01-31 22:53 WA9PIE Status new => acknowledged
2014-01-31 22:54 WA9PIE Status acknowledged => confirmed
2014-02-02 14:45 WA9PIE Summary HRD Rotator incompatible with Azimuth & Elevation range of Yaesu model G-5500 rotator => Bug: HRD Rotator incompatible with Azimuth & Elevation range of Yaesu model G-5500 rotator
2015-09-17 13:09 WA9PIE Module (select) => Rotator
2015-09-17 13:15 WA9PIE Category Rotator => Bug
2015-09-17 13:19 WA9PIE Project @5@ => 1 - Backlog
2015-09-29 16:08 WA9PIE Fix Build => (select)
2015-09-29 16:08 WA9PIE Summary Bug: HRD Rotator incompatible with Azimuth & Elevation range of Yaesu model G-5500 rotator => HRD Rotator incompatible with Azimuth & Elevation range of Yaesu model G-5500 rotator
2015-10-12 13:03 ag6hq Note Added: 0000641
2018-03-04 00:53 WA9PIE Status confirmed => assigned
2018-03-04 00:53 WA9PIE Assigned To => JOSE
2018-03-04 00:54 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-03-04 00:56 WA9PIE Testing => Not Started
2019-02-26 18:08 WA9PIE Note Added: 0007516
2019-08-30 02:44 JOSE Status assigned => resolved
2019-08-30 02:44 JOSE Resolution open => fixed
2019-08-30 02:44 JOSE Fixed in Version => 6.7.0.226
2019-09-01 02:51 PD9FER Note Added: 0008483
2019-09-07 08:44 WA9PIE Assigned To JOSE => PD9FER
2019-09-07 08:44 WA9PIE Note Added: 0008522
2019-09-08 02:37 PD9FER Note Added: 0008539
2019-09-13 23:42 WA9PIE Note Added: 0008544
2019-09-23 05:57 g3ucq Note Added: 0008599
2019-09-23 13:28 PD9FER Note Added: 0008613
2019-09-24 00:16 WA9PIE Note Added: 0008626
2019-10-16 07:54 PD9FER Note Added: 0008828
2019-10-17 14:08 PD9FER Note Added: 0008845
2019-10-17 14:16 KB3NPH Note Added: 0008846
2019-10-28 16:31 WA9PIE Note Added: 0009040
2019-11-08 02:16 WA9PIE Fixed in Version 6.7.0.226 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe