View Issue Details

IDProjectCategoryView StatusLast Update
0000561Ham Radio DeluxeBugpublic2019-02-24 15:13
ReporterW4PCAssigned ToJOSE 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformAcer V5-471 (8GB RAM)OSWindows 8OS VersionPro
Product Version 
Target VersionFixed in Version6.5.0.196 
Summary0000561: Elevation does not display in Rotator Gauge
DescriptionAfter successfully connecting to Yaesu GS232B rotor controller, HRD Rotator controller does not update Rotator (or SatTrack) elevation gauge when it is displayed. The EL gauge reads "0 deg" continuously. Confirmed that HRD Rotator is reading current rotator position correctly as displayed in Logfile tab, but it appears to not be processed further by HRD in preparation for display on the gauge. It may also be that in addition to Rotator not completing processing of EL position data coming in that SatTrack is likewise not receiving current EL position data via DDE. When GS232B Az-El protocol is selected, azimuth gauge is being updated with current az position from rotator, so it's just elevation position display that seems to be the problem. (Note: when GS232A Az-El protocol is selected, azimuth gauge is likewise NOT being updated; that problem will be reported in a separate bug report).
Steps To Reproduce(1) Connect Yaesu GS232B rotator controller device to computer USB port via USB-serial adapter cable (FTDI chipset based cable adapter connection used in my configuration). First time when plugging in the USB cable will cause Windows 8 to install a WHQL FTDI driver already contained in Windows (in most instances).
(2) Since HRD Rotator does not auto-detect its COM port (!), open Windows Device Manager, selected Hardware Devices, select Ports, and determine which COM port number is used by the Yaesu GS232B (COM9 in my configuration is used).
(3) Configure HRD Rotator...Protocol: GS232B Az-El, Serial Port: COM9 (or whatever is the correct one found in Device Manager), Speed: 9600, Update: 1 second (or 2secs); I named my configuration preset profile "G5500" to reflect the model Yaesu G-5500 az-el rotator being used (& controlled by the GS232B controller).
(4) Make sure HRD Rotator is configured with "Gauges" displayed (button on right selected, gauges displayed on far left pane). When an Az-El protocol is selected, there should be 2 gauges displayed, one for azimuth and one for elevation.
(5) Click on "Connect" button; HRD Rotator will connect to the GS232B controller and begin communicating with it. The "Logfile" tab should then begin showing the series of sent & received data with the GS232B, beginning with serial port configuration and eventually issuing the "C2" command (which is the command request for position data). The GS232B will respond to the C2 command with both AZ and EL position values (ASCII decimal values for degrees when converted from hex values, which can be seen by selecting "Text" display). This command sequence will repeat at the periodic update rate.
(6) Manually rotate the Yaesu rotator, using the GS232B device elevation controls. Note that despite the Logfile showing correct elevation position data being received from the GS232B controller, the EL gauge does not move and remains showing a 0 degrees position. Ditto for SatTrack, IF it is running also and connected to Rotator via DDE.
Additional InformationHRD v6.1.4 build 189
TagsNo tags attached.
ModuleRotator
Sub-Module(select)
Testing Beta Successful

Activities

user19

2014-01-31 20:31

  ~0000276

I experienced this exact failure. A re-install resolved it. However, my OS was Win 7 and not 8. Might be significant, might now.

Jim - KB1NXE

ag6hq

2015-10-12 12:54

viewer   ~0000640

I also have this issue with both Az and El displays.
I am using an AMSAT sold LVB Tracker instead of Yaesu brand interface

Below is the return for +019° Az and +019° El:
I suspect the issue is there are 8 bytes received after CR/LF, and that is was is being used for readings, instead of the 10 bytes prior to CR/LF



10:41:43 COM3 Get status> Send 43-32-0D
10:41:43 COM3 Get status> Recv 2B-30-30-31-39-2B-30-30-31-39-0D-0A-00-00-00-00-00-00-00-00
10:41:49 COM3 Get status> Send 43-32-0D
10:41:49 COM3 Get status> Recv 2B-30-30-31-39-2B-30-30-31-39-0D-0A-00-00-00-00-00-00-00-00

ASCII Interpretation:

Send C2[CR]
Recv +0019+0019[CR][LF]00000000

JOSE

2019-02-12 21:12

developer   ~0007363

Changes to address issues with protocols GS232B/GS232A have been made.

WA9PIE

2019-02-21 09:31

administrator   ~0007471

Validated

Issue History

Date Modified Username Field Change
2013-12-21 18:56 W4PC New Issue
2013-12-21 18:57 W4PC Project 2 - Next Dev List (Holding Area) => @5@
2014-01-31 20:31 user19 Note Added: 0000276
2014-01-31 22:53 WA9PIE Release => (select)
2014-01-31 22:53 WA9PIE Module => (select)
2014-01-31 22:53 WA9PIE Sub-Module => (select)
2014-01-31 22:53 WA9PIE Report Build => (select)
2014-01-31 22:53 WA9PIE Status new => confirmed
2014-02-02 14:46 WA9PIE Summary Elevation does not display in Rotator Gauge => Bug: Elevation does not display in Rotator Gauge
2015-09-17 13:09 WA9PIE Module (select) => Rotator
2015-09-17 13:15 WA9PIE Category Rotator => Bug
2015-09-17 13:19 WA9PIE Project @5@ => 1 - Backlog
2015-09-29 16:08 WA9PIE Fix Build => (select)
2015-09-29 16:08 WA9PIE Summary Bug: Elevation does not display in Rotator Gauge => Elevation does not display in Rotator Gauge
2015-10-12 12:54 ag6hq Note Added: 0000640
2018-03-04 00:53 WA9PIE Status confirmed => assigned
2018-03-04 00:53 WA9PIE Assigned To => JOSE
2018-03-04 00:54 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-03-04 00:56 WA9PIE Testing => Not Started
2019-02-12 21:12 JOSE Status assigned => resolved
2019-02-12 21:12 JOSE Resolution open => fixed
2019-02-12 21:12 JOSE Fixed in Version => 6.5.0.192
2019-02-12 21:12 JOSE Note Added: 0007363
2019-02-21 09:31 WA9PIE Status resolved => closed
2019-02-21 09:31 WA9PIE Testing Not Started => Beta Successful
2019-02-21 09:31 WA9PIE Note Added: 0007471
2019-02-24 14:36 WA9PIE Fixed in Version 6.5.0.192 => 6.5.0.196
2019-02-24 15:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe